On February 10, 2026, between approximately 10:15 PM and 11:30 PM CET, some Prismic customers experienced difficulties logging in and accessing their repositories. These issues were caused by a DNS resolution failure on AWS CloudFront, one of the infrastructure providers Prismic relies on.
AWS identified the root cause and progressively restored normal operations.
All Prismic services returned to full availability by late evening CET.
We identified gaps in our alerting that delayed our awareness of the issue.
To improve our response to similar events in the future, we are taking the following actions:
Improving our alerting: We are enhancing our monitoring to detect upstream infrastructure issues faster and more reliably.
Better support readiness: We are putting in place clearer escalation processes so our support team can assist customers more effectively during incidents.
Faster communication: We are improving our status page update process to ensure customers are informed promptly when an issue is identified.
We apologize for the inconvenience and appreciate your patience. If you have any questions, please don't hesitate to reach out to our support team.
Resolved
On February 10, 2026, between approximately 10:15 PM and 11:30 PM CET, some Prismic customers experienced difficulties logging in and accessing their repositories. These issues were caused by a DNS resolution failure on AWS CloudFront, one of the infrastructure providers Prismic relies on.
AWS identified the root cause and progressively restored normal operations.
All Prismic services returned to full availability by late evening CET.
We identified gaps in our alerting that delayed our awareness of the issue.
To improve our response to similar events in the future, we are taking the following actions:
Improving our alerting: We are enhancing our monitoring to detect upstream infrastructure issues faster and more reliably.
Better support readiness: We are putting in place clearer escalation processes so our support team can assist customers more effectively during incidents.
Faster communication: We are improving our status page update process to ensure customers are informed promptly when an issue is identified.
We apologize for the inconvenience and appreciate your patience. If you have any questions, please don't hesitate to reach out to our support team.
Investigating
Prismic customers experienced difficulties logging in and accessing their repositories